Installation, updates, general problem solving and assistance.

2016-06-10 17:42 »

1. I only added 'explorer.exe' 'cause it's POPPeepers' parent,
and I thought, maybe, that it might use that as the source for
the rule.

2. The IE icons' Properties in taskbar (Win10, which I pinned
from the 64bit version; also, I don't like the START either since
it doesn't work (when doing 'all apps', if I type in a letter
(A-Z) to see my program, it just puts up a blank white window
(rectangle on end) which needs ESC to get rid of, so I'm FORCED
to scroll down the list and then select it...SO MUCH USELESS/PRONE
TO MISTAKES work by the user???!!!))

shows it is NOT from x86:
"C:Program FilesInternet Exploreriexplore.exe"

Anyway, I added a new OB rule:
Rule Name: ALLOW iexplore.exe-32
Enabled: Yes
Direction: Out
Profiles: Domain,Private,Public
LocalIP: Any
RemoteIP: Any
Protocol: Any
Edge traversal: No
Program: C:Program Files (x86)Internet Exploreriexplore.exe
InterfaceTypes: Any
Security: NotRequired
Rule source: Local Setting
Action: Allow

but it made no difference. Once again, they both failed, I added
the service back to the WinUpd OB rule, and, again, w/o
re-starting anything, they then both worked.

3. And anyway, this wouldn't explain POPPeepers' failure...

4. nor Win7s'. On both, I did:

C:>dir /s /a /x iexplore.exe

Win7 only has this:
Directory of C:Program FilesInternet Explorer
12/16/2011 02:03 AM 673,048 iexplore.exe

while Win10 does have both:
Directory of C:Program FilesInternet Explorer
10/30/2015 01:18 AM 816,320 iexplore.exe

Directory of C:Program Files (x86)Internet Explorer
10/30/2015 01:19 AM 819,904 iexplore.exe

and both have winsxs entries.

BTW: normally, I don't need to Enable any of my ALLOW rules
when the WinUpd rule has the service in it...

User avatar
Posts: 3278
Joined: 2013-02-25 18:36

2016-06-13 11:57 »

Weird behaviour but then again, it's Windows. Nothing makes sense in it anymore! :sick:


2017-03-20 01:24 »

Hello, thanks for your posts, OP: I implemented the firewall hack in Win10, just letting through progs I trusted and switching to "recommended settings" when I wanted an update (and back to my personal firewall policy afterwards, of course).

Everything went fine for nearly a year, but now I get "error 87 / invalid parameter" when trying to import said policy. Note that it isn't a corrupt file, as the dozen or so policies I saved all show the same error. And it isn't a software glitch either as saving/importing new policies works OK.

Has MSoft silently changed something in the way the policies are now saved? :evil:

I googled around a lot but couldn't find any information on this specific error, or even on the (binary) format of the .wfw files Windows uses for exporting the settings.

As I now have to rebuild my settings from scratch, a word of caution: save your settings also in the tab-separated text format available with a right click on the Inbound Rules (& Outbound Rules) folder(s) in the advanced firewall interface, then clicking Export List in the popup menu. You won't be able to re-import these lists, but at least they are human readable (e. g. with some spreadsheet).

Hope that helps. Good luck!

Post Reply