Installation, updates, general problem solving and assistance.
Steven W
VIP
Posts: 2427
Joined: 2013-08-10 22:40

2022-06-21 04:26 »

Okay, the issue:

Audio starts to sound distorted crackle-y on, well it happens on Ubuntu Mint for me.

How to recreate (to see if it affects your HW)
  • Start a music video on Youtube.
  • Open bbc.co.uk in a new tab.
Fix (works for me)
about:config
search 'audio'

media.audio.audiosink.threshold_ms
400

dom.audioworklet.enabled
false

dom.webaudio.enabled
false

:mrgreen:

I thought about putting this in Hardware. Eh, move it if you wanna.

Steven W
VIP
Posts: 2427
Joined: 2013-08-10 22:40

2022-06-21 04:37 »

FUCK! That wasn't it, but I'm trying something else now. Seems to have temporarily helped.

media.audio.audiosink.threshold_ms
400

browser.tabs.delayHidingAudioPlayingIconMS
0

I swear to God, if this whole issue is caused that delay setting... :sick:

Steven W
VIP
Posts: 2427
Joined: 2013-08-10 22:40

2022-06-21 04:40 »

Steven W wrote:
2022-06-21 04:37
FUCK! That wasn't it, but I'm trying something else now. Seems to have temporarily helped.

media.audio.audiosink.threshold_ms
400

browser.tabs.delayHidingAudioPlayingIconMS
0

I swear to God, if this whole issue is caused that delay setting... :sick:
Well, that seems to have worked after 5 retries. I guess I keep an eye on it for a week or so and let anyone reading this know.

Steven W
VIP
Posts: 2427
Joined: 2013-08-10 22:40

2022-06-21 05:27 »

Well, running into the issue, but somehow it's not as bad.

Let's add one more config change:

media.navigator.audio.use_fec
false

That's still in addition to:

media.audio.audiosink.threshold_ms
400

browser.tabs.delayHidingAudioPlayingIconMS
0

Steven W
VIP
Posts: 2427
Joined: 2013-08-10 22:40

2022-06-21 06:18 »

Here's what I'm settling on so far. I'm not gonna call this a total fix. There seems to be two issues going on. A delay gets introduced and the distortion.
at_least_partial_fix.jpg
at_least_partial_fix.jpg (78.5 KiB) Viewed 99 times
These settings seem to stop the delay:

media.audio.audiosink.threshold_ms
400

browser.tabs.delayHidingAudioPlayingIconMS
0

I'm hoping the other two settings, in the screenshot, will at least reduce the likelihood of the distortion starting.

Steven W
VIP
Posts: 2427
Joined: 2013-08-10 22:40

2022-06-22 23:20 »

Eh, it ain't a fix, but I can almost always Youtube and the BBC without it going wonky now. That said, I did find another site that will ALWAYS cause the issue with Youtube. :lol:

Steven W
VIP
Posts: 2427
Joined: 2013-08-10 22:40

2022-06-22 23:46 »

meg-ryan-big_O.gif
meg-ryan-big_O.gif (3.58 MiB) Viewed 83 times
Okay, now even the site that was causing it every time isn't

I doubt all of these are necessary, but this is what I got:

media.audio.audiosink.threshold_ms
400.0

The following are all set '0':
media.audio.playbackrate.soundtouch_overlap_ms
media.audio.playbackrate.soundtouch_seekwindow_ms
media.audio.playbackrate.soundtouch_sequence_ms

media.autoplay.block-webaudio
true

media.navigator.audio.use_fec
false

media.rdd-webaudio.batch.size
1

media.rdd-webaudio.batch.size
false

media.webspeech.synth.enabled
false

reader.parse-on-load.enabled
false

Steven W
VIP
Posts: 2427
Joined: 2013-08-10 22:40

2022-06-22 23:51 »

oops! Better yet, I can copy/pasta:

browser.tabs.delayHidingAudioPlayingIconMS 0
media.audio.audiosink.threshold_ms 400.0
media.audio.playbackrate.soundtouch_overlap_ms 0
media.audio.playbackrate.soundtouch_seekwindow_ms 0
media.audio.playbackrate.soundtouch_sequence_ms 0
media.autoplay.block-webaudio true
media.navigator.audio.use_fec false
media.rdd-webaudio.batch.size 1
media.webspeech.synth.enabled false
reader.parse-on-load.enabled false

Steven W
VIP
Posts: 2427
Joined: 2013-08-10 22:40

2022-06-27 03:59 »

Better yet, agin

browser.tabs.delayHidingAudioPlayingIconMS 0
media.audio.audiosink.threshold_ms 400.0
media.autoplay.block-webaudio true
media.navigator.audio.use_fec false
media.rdd-webaudio.batch.size 1
media.webspeech.synth.enabled false
reader.parse-on-load.enabled false

Post Reply