Installation, updates, general problem solving and assistance.
Z-Balm
0%
Posts: 9
Joined: 2015-09-18 02:36

2016-02-29 06:22 »

I joined this forum several months ago after downloading USP_v3.48.

I have several ways to restore a system, including numerous partial and full backups.
Nothing can happen that can't be undone. I'm sure most of you follow similar procedures.

I'm a partner in a business that started when Windows 95 was new. Maybe that's why I'm
reluctant to abandon 98SE forever. If I can't successfully install an Unofficial Service Pack
and update the USB drivers I will save any useful files and wipe the system. I really don't
want to do that.

I used a backup to restore my system after reading the help file and bogging down with
that very lengthy options list (see attached jpeg).

Problem One:

After the extraction completes a help file appears. These instructions for deleting all the
old USB drivers and replacing them with 2.0 is something I tried a couple of years ago.
I didn't save the driver pack, but it was downloaded from the Everything USB Community.
The results were terrible. Dozens of system wide error messages and the dreaded BSOD.

"USB 2.0 - Install USBSTACK.EXE inside C:WindowsSystem directory if you would like
updated USB drivers. Unplug all USB devices. Remove all current USB/EHCI drivers +
controllers from Device Manager in safe mode. REBOOT! When removing USB drivers
while in SAFE MODE, you NEED to be using a PS/2 mouse or keyboard. USB mouse and
keyboard drivers MUST be deleted also. Let all drivers redetect on startup. Plug in USB
devices one at a time. If a BSOD occurs while updating USB devices, use the VIA Chipset
drivers instead. If no new USB drivers have been added, then you only need to do this
procedure (Once)!"


I'd like to try again with your help.

If I understand the instructions correctly, I delete all USB items while in SAFE MODE and
immediately run USBSTACK.EXE. When the new USB 2.0 drivers complete extraction I
reboot the system. Correct?

In Device Manager I'll delete everything under Universal Serial Bus Controllers, Keyboard,
and Mouse. Under Hard Disk Controllers I'll delete the WinTricks Generic Driver for my USB
sticks. In the Printer folder I'll delete my Canon AIO printer. There are also two virtual
printers for creating PDFs. CutePDF Writer and SolidPDF XChange. I don't see any reason
for deleting these virtual printers.

The software for my mouse and printer are dependent on the old drivers. When the mouse
and printer drivers are replaced, will the software continue to function? If the answer is "no"
I'm dead in the water.

Problem Two:

I consider myself an advanced computer user, but that options list was overwelming.

The warning at the top about IE core files is not logical. IE_v6.0 is completely dead
on the internet. 6.0 was the last version compatible with 98SE. When I connect to
the web with 98SE I use a third party browser like SeaMonkey, Opera, etc.

I didn't count the number of items on the options list, but it's a lot! Maybe 75% of the
items are easy to select or deselect. I need to be 100% confident about all the items
on the options list before installing a USP. Is there a detailed explanation for each item
on the list?

I apologize for this lengthy post. Without help I cannot attempt another USP install with
updated drivers.

Thanks guys.
Attachments
List of Options.jpg
List of Options.jpg (67.79 KiB) Viewed 2901 times

User avatar
PROBLEMCHYLD
VIP
Posts: 628
Joined: 2013-03-22 12:55

2016-02-29 07:19 »

Are you running a clean installation?

Yes, you are correct about the USB instructions. What is the make of the motherboard/chipset?

Z-Balm
0%
Posts: 9
Joined: 2015-09-18 02:36

2016-03-01 01:17 »

No, it is definitely not a clean installation.

Because my post was several paragraphs, I didn't want to mention slipstreaming.
Remember those early service packs from Microsoft. They were a disaster! The
only way they could be smoothly integrated was to burn a new CD with the combined
files from the service pack and the original Windows files. I slipstreamed a few
service packs, but it always required a fresh install. Not many people were willing
to do that!

I've got an IBM ThinkPad that was designed for XP. That's where my copy of 98SE is
installed. You can see the attached jpeg from an app called Dr. Hardware. Unfortunately,
when I selected the chipset tab there was no info. A dialog box appeared asking if I wanted
to see the help file.

It just wouldn't make sense to perform a fresh install of 98SE. My copy is filled with software,
scripts I've created, many Registry hacks, well, you get the idea.

I'm guessing the majority of people who use these Unofficial Service Packs perform a fresh
install. Integrating all those new files into an established system without problems is not
realistic.

Should I try anyway, or is it time to retire my ThinkPad?
Attachments
Motherboard Info.jpg
Motherboard Info.jpg (97.21 KiB) Viewed 2888 times

User avatar
!
25%
Posts: 2539
Joined: 2013-02-25 18:36

2016-03-01 09:39 »

Z-Balm wrote:...Should I try anyway, or is it time to retire my ThinkPad?...

I cannot answer your questions but as a side note, you could maybe copy an image of your drive and virtualize it. That way, you could test a lot of stuff without actually "breaking" your system, with virtual machine snapshots, you can just revert back the entire operating system to an earlier or "original" version. Just a thought. :oops: :think:

Come to think of it, you could maybe image your entire drive anyway and then test all this. If something breaks, you can just reimage the drive back to the "original" state. :idea:

User avatar
PROBLEMCHYLD
VIP
Posts: 628
Joined: 2013-03-22 12:55

2016-03-01 14:08 »

I would try it. I don't know what other unofficial packs you have installed, but SP3 may conflict with them. Back up everything first. Run the installer, choose Main Updates and reboot. Report back here. We'll take it slow.

Z-Balm
0%
Posts: 9
Joined: 2015-09-18 02:36

2016-03-02 04:38 »

We all have secrets. One of mine is not telling my business partners that I still use 98SE!

I have an extensive electronics background. I like building things in a shop. When
people visit our offices they see my partners wearing expensive suits. I'm the senior
partner, but I would rather be shot than sit behind a desk.

98SE is a wonderful system for tweaking. I like creating scripts that change how things
work. That why I keep using this old system.

I'm never concerned about restoring a damaged system. I've got USB sticks with a couple
of dozen apps that are bootable. They all run before Windows starts. I can restore a single
file or the entire system. One of the apps is ATI (Acronis True Image).

I'll download the latest Unofficial Service Pack and see what happens.

I really appreciate your replies.

User avatar
!
25%
Posts: 2539
Joined: 2013-02-25 18:36

2016-03-02 08:44 »

Z-Balm wrote:We all have secrets. One of mine is not telling my business partners that I still use 98SE!...

Hahahhahaha... they would freak out! Actually, I would too, although, once the shock has settled, it is pretty impressive. It is now almost an art form using such old software with success! :clap:

Z-Balm wrote:...I'm the senior
partner, but I would rather be shot than sit behind a desk...

I know the feeling... :thumbup: :thumbup: :thumbup:

Nice, I didn't know about Acronis True Image. Fair price too! Yes indeed, when you have an image, then it is safe to do all kinds of tests. :smile:

Z-Balm
0%
Posts: 9
Joined: 2015-09-18 02:36

2016-03-05 11:13 »

I'm not giving up yet, but there were problems with USP_v3.53 and my very "unfresh"
system.

After the install completed the restart was very slow because so many new files were added.
Things looked ok, but all was not well.

I assumed the help file that appears before the install begins would be available after
the install. There was no Desktop or Start Menu shortcut. The temporary folders were
empty. Where did the help file go?

The driver update package USBSTACK.EXE was not in C:WindowsSystem. I used the
Windows search applet hoping to find USBSTACK.EXE somewhere on the hard disk. It was
not an item on the options list at the beginning of the install, so it should have been extracted
to the System directory.

The first restart was ok, but when I attempted another reboot I got the BSOD. Some
BSODs are easily dismissed because you understand why they occurred. A BSOD that
halts a system startup or shutdown is the reason we have backups. Restoring my system
from a backup was a five minute procedure.

I'll try again if you can tell me why I couldn't find the help file or USBSTACK.EXE.

Z-Balm
0%
Posts: 9
Joined: 2015-09-18 02:36

2016-03-06 01:49 »

No replies?

I joined MSFN years ago because they had all the info about 98SE and KernelEx. MSFN had an active group always
discussing these Unofficial Service Packs. I found this forum (Tech Talk) accidentally while performing a Google search.

Please guys, don't leave me hanging. If you don't know why I couldn't find the help file or USBSTACK.EXE just
tell me something went wrong with the extraction that you don't understand. You're the experts here, not me.

User avatar
!
25%
Posts: 2539
Joined: 2013-02-25 18:36

2016-03-06 03:10 »

No man, we are not forgetting you. I was under the impression that you were getting back to us with more information. :lol: ...I have been so busy this week, haven't had a chance to delve into your post yet, I'm saving it for my Monday read. I'm sure PROBLEMCHYLD will also get back to you but I'm guessing he too, is a bit busy, especially during weekends, with kids and all. :mrgreen: :grin:

Post Reply